Azure Arc-enabled Kubernetes cluster Connect Elevation of Privilege Vulnerability

Stammdaten

Kritikalität
CVE ID
CVE-2022-37968
Aktualisiert am:
2024-07-09T17:23:33.779Z
Veröffentlicht am:
2022-10-11T00:00:00
 

Betroffene Produkte

Hersteller:
Microsoft
Produkt(e):
Azure Arc-enabled Kubernetes cluster 1.8.11, Azure Arc-enabled Kubernetes cluster 1.7.18, Azure Arc-enabled Kubernetes cluster 1.5.8, Azure Arc-enabled Kubernetes cluster 1.6.19, Azure Stack Edge
Betroffene Version:
1.0.0
 

Beschreibung

Microsoft has identified a vulnerability affecting the cluster connect feature of Azure Arc-enabled Kubernetes clusters. This vulnerability could allow an unauthenticated user to elevate their privileges and potentially gain administrative control over the Kubernetes cluster. Additionally, because Azure Stack Edge allows customers to deploy Kubernetes workloads on their devices via Azure Arc, Azure Stack Edge devices are also vulnerable to this vulnerability.
 

Referenzen

 

NIST-Link:


Copyright © 2024 · All Rights Reserved · https://www.tecxero.com | Impressum